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Overview 
The SampleVideo project illustrates how to embed a YouTube video in a source document that 

you process in WebWorks ePublisher. Users who view the ePublisher HTML output, such as an 

online help website, can play the video. 

In this sample project, I created the source document (SampleVideo.docx) in Microsoft Word 

2016. You can use similar techniques to embed videos in Adobe FrameMaker or DITA source 

documents. 

You can use the Word ribbon tools or ePublisher passthrough code to embed the videos. The 

best approach depends on the kinds of output that you plan to generate from the DOCX files, 

and how you want the users to view the videos. 



I created the project in WebWorks ePublisher Designer. The project has an almost factory-

default configuration, except for the video configurations described explicitly below. The project 

has the following outputs: 

• Reverb2: This output illustrates HTML5 online help with a responsive UI. To view this 

output, open the following file in a browser: 

SampleVideo\Output\Reverb2\index.html 

• DHTML: This output illustrates Dynamic HTML, used mainly for integrating the 

ePublisher output into other systems. To view the output, open the following file: 

SampleVideo\Output\DHTML\SampleVideo\toc.html (or open any of the other HTML 

files in the folder) 

• Independently of ePublisher, I generated a PDF by running the Word > Save As > PDF 

command. To view the PDF, open the following file: 

SampleVideo\SampleVideo.pdf 

The sample video that I used in this project is a WebWorks training session entitled "Reverb 2.0 

The Do's and the Really Do's": 

https://www.youtube.com/watch?v=PeIV2XgNs2o&t=125s 

Approach 1: Insert a Hyperlink to a Video 
The simplest way to insert a video is to enter a hyperlink to its URL. This approach does not 

embed the video in the project. Rather, a user can click the link and view the video on the 

YouTube website.  

Procedure: 

1. On the Word ribbon, click Insert > Link. 

2. In the left pane of the dialog box, select Existing File or Web Page. 

3. In the Address box, paste the YouTube URL. In our example: 

https://www.youtube.com/watch?v=PeIV2XgNs2o&t=125s 

4. In the Text to Display box, type any desired text. If you wish, the text can be a copy of 

the URL. 

5. Save the DOCX file. 

6. Generate the WebWorks ePublisher project. 

7. Display the project output. You can click the link and view the video on the YouTube 

site. 

Video behavior: 

• In Word and in all the output formats, you do not see an image of the video. Rather, you 

see only a textual link. 

• When you click the link, the YouTube site opens in a browser tab. You can play the 

video, and you can zoom it to full screen.  

• Below and next to the video, YouTube displays text, comments, and links to other videos 

that the user might choose to play. 

Example: 

https://www.youtube.com/watch?v=PeIV2XgNs2o&t=125s


• This paragraph contains a link to the sample video at: 

https://www.youtube.com/watch?v=PeIV2XgNs2o&t=125s 

Approach 2: Insert > Online Video Command 
You can use the Online Video command, located on the Insert tab of the Word ribbon, to embed 

a YouTube video. The result is similar to Approach 1, except that the user sees an image of the 

video rather than a textual link. 

Procedure: 

1. On the Word ribbon, click Insert > Online Video. 

2. In the dialog box, paste the YouTube URL. In our example: 

https://www.youtube.com/watch?v=PeIV2XgNs2o&t=125s 

3. Optionally, right-click the video and format the Word display. For example, you can set 

the Size parameters. 

If you click the Edit Link command, you can edit the URL. Notice that Word has altered 

the URL parameters slightly: 

https://www.youtube.com/embed/PeIV2XgNs2o?start=125&feature=oembed 

4. Save the DOCX file. 

5. Generate the WebWorks ePublisher project. 

6. Display the project output. If you click the image, the video opens in a new browser tab. 

Video behavior: 

• In Word, you can play the video in a small window. You cannot zoom the video to full 

screen. 

• In the Reverb2, DHTML, or PDF output, the video displays as a static image that does not 

have a Play button or any other obvious video controls. If you click the image, the video 

plays in a new browser tab. You can zoom the video to full screen. 

• The video displays in a player window, not in the full YouTube page display. This means 

that the user does not see text or links below or next to the video. 

Example: 

https://www.youtube.com/watch?v=PeIV2XgNs2o&t=125s


 

Approach 3: Insert WebWorks Passthrough Code 
In the pass-through approach, you insert HTML code that displays the YouTube video directly in 

the Word source document. You configure the WebWorks ePublisher project to pass the code 

verbatim to the HTML output. 

The advantage of this approach is that the video is embedded within the HTML topic page 

where you placed it. The user can view the video without leaving the page. The disadvantage is 

that you cannot view the video in Word or in a PDF. 

There are three ways to configure the passthrough behavior in the ePublisher project: 

• In a passthrough marker 

• In a passthrough condition 

• In a passthrough style 

The video behavior is identical in all of these methods. The following sections describe all three 

methods. 

Passthrough Code 
The following lines illustrate the passthrough code that displays the sample YouTube video: 

<iframe type="text/html" width="640" height="360" 

src="http://www.youtube.com/embed/PeIV2XgNs2o?enablejsapi=1&origin=http://almondweb

.com" frameborder="0" allowfullscreen="true"></iframe> 

To embed your own YouTube videos, copy this code, and edit the bold-italic values as follows: 

https://www.youtube.com/embed/PeIV2XgNs2o?start=125&feature=oembed


1. On the YouTube site, browse to the video. Our sample video is located at: 

https://www.youtube.com/watch?v=PeIV2XgNs2o&t=125s 

2. Right-click the video, and click Stats for Nerds. 

YouTube displays a statistics pane: 

 
3. From the Video ID parameter, copy the Video ID parameter, and paste it into the 

passthrough code.  

PeIV2XgNs2o 

4. From the Viewport/Frames parameter, copy the width and height of the video. Scale the 

sizes as desired, and enter them in the passthrough code. In our example, we scaled by 

88%: 

width = 727 pixels * 0.88 = 640 

height = 409 pixels * 0.88 = 360 

5. Enter the URL of your company's website (the site where you plan to upload the 

WebWorks output): 

http://almondweb.com 

For more information about these and other parameters that you can insert in the passthrough 

code, see the YouTube developer documentation: 

https://developers.google.com/youtube/player_parameters 

Passthrough Marker 
In this example, we insert the video in a WebWorks marker, which is implemented as a Word { 

PRIVATE WWF PassThrough } field code. 

Procedure: 

1. In Word, display hidden text so you can view the marker. 

2. On the ribbon, click Add-ins > WebWorks > Markers. 

3. In the list, select a PassThrough marker. 

4. In the Value box, paste the Passthrough Code. 

5. Save the DOCX file. 

6. Generate the WebWorks ePublisher project. 

7. Display the project output. The video displays a Play button. Optionally, while the video 

is playing, you can click the Full Screen button and expand it to fill your screen. 

Video behavior: 

• In Word, you cannot play the video. You must display hidden text to view the field code. 

https://developers.google.com/youtube/player_parameters


• In the Reverb2 or DHTML output, the video displays as a static image that has a Play 

button. When you click the button, the video plays on the current HTML page. You can 

zoom the video to full screen. 

• In a PDF, neither the video nor the field code are displayed. 

Example: 

The following example is visible in Word only if you display hidden text. It is not visible in a PDF. 

 

Passthrough Condition 
This example is similar to a Passthrough Marker, except you enter the passthrough code in a 

conditional paragraph instead of a field code. 

Procedure: 

1. In the Word document, paste the Passthrough Code. 

2. Select the HTML code that you pasted. 

3. On the Word ribbon, click Add-ins > WebWorks > Conditions. 

4. Click the + button and define a condition having a name such as PassThrough. Apply the 

condition to the selection. You can configure the condition as either Hidden or Visible. 

We recommend that you configure it with a highlight color, so you can find and edit the 

passthrough code easily. 

5. In the WebWorks ePublisher Designer project, select a target, and click Target > 

Conditions. Configure the PassThrough condition with the properties Visible and Pass 

Through. 

Repeat this step for each target in the project. 

6. Generate the project. 

7. Display the project output. The video displays a Play button. Optionally, while the video 

is playing, you can click the Full Screen button and expand it to fill your screen. 

Video behavior: 

• In Word, you cannot play the video. If you configured the condition as Hidden, you must 

display hidden text to view the code. 

• In the Reverb2 or DHTML output, the video displays as a static image that has a Play 

button. When you click the button, the video plays on the current HTML page. You can 

zoom the video to full screen. 

• In a PDF, if you configured the condition as Visible, the HTML code is displayed instead 

of the video. If you configured the condition as hidden, nothing is displayed. 

Example: 

<iframe type="text/html" width="640" height="360" 

src="http://www.youtube.com/embed/PeIV2XgNs2o?enablejsapi=1&origin=http://almondweb.

com" frameborder="0" allowfullscreen="true"></iframe> 



Passthrough Style 
This example is similar to a Passthrough Marker, except that you enter the passthrough code in 

a regular paragraph instead of a field code. You must apply a special style name to the 

paragraph. 

Procedure: 

1. In an empty paragraph of the Word document, paste the Passthrough Code. 

2. In the Word styles pane, define a paragraph style having a name such as Passthrough. 

We recommend that you define the style with a distinctive color, so you can find the 

passthrough code easily. Configure the style as visible (not hidden).  

3. Apply the Passthrough style to the paragraph where you pasted the code. 

4. Optionally, surround the code with a <div class-"Passthrough">...</div> element. This 

element ensures that the video is displayed with the formatting of the Passthrough 

paragraph style. 

5. In the WebWorks ePublisher Designer project, click View > Style Designer > Paragraph 

Styles. Select the Passthrough style. On the Options tab, set Pass Through = Enabled. 

Optionally, on the Properties tab, you can configure the style formatting, such as the 

margins (whitespace) around the style. 

6. Generate the project. 

7. Display the project output. The video displays a Play button. Optionally, while the video 

is playing, you can click the Full Screen button and expand it to fill your screen. 

Video behavior: 

• In Word, you cannot play the video. You can view and edit the passthrough code 

whether or not hidden text is displayed. 

• In the Reverb2 or DHTML output, the video displays as a static image that has a Play 

button. When you click the button, the video plays on the current HTML page. You can 

zoom the video to full screen. 

• In a PDF, the passthrough code is displayed instead of the video. 

Example: 

<div class="Passthrough"><iframe type="text/html" width="640" height="360" 

src="http://www.youtube.com/embed/PeIV2XgNs2o?enablejsapi=1&origin=http://almondweb.

com" frameborder="0" allowfullscreen="true"></iframe></div> 

Recommendations for Online Help Projects 
To display a YouTube video in an HTML-based online help project, we recommend Approach 3: 

Insert WebWorks Passthrough Code.  

• For the author, it takes only a minute or two to enter and edit the code.  

• For the users, the video plays without leaving the online-help browser tab. Optionally, 

the users can zoom the video to fully screen. 



If you do not plan to generate PDF output, we recommend inserting the passthrough code in a 

Passthrough Style. In Word, the author can find and edit the code even if hidden text is not 

displayed. 

Unfortunately, the passthrough approach does not work with PDF output. If you plan to 

generate PDFs in addition to the HTML output, we recommend that you insert two copies of the 

video: 

1. For the benefit of the PDF, insert the first copy of the video by Approach 1: Insert a 

Hyperlink to a Video or Approach 2: Insert > Online Video Command. 

2. Format this first copy of the video in a paragraph style that you configure not to 

generate in ePublisher. For example, you might call the style PDFOnly. 

To configure a style not to generate, open the ePublisher Designer project, and click 

View > Style Designer > Paragraph Styles > (style name) > Options > Generate Output = 

Disabled. 

3. For the benefit of the HTML, insert the second copy in a Passthrough Marker, or in a 

Passthrough Condition that you configure as hidden text.  

4. When you generate the PDF, be sure to hide hidden text. This causes the second copy to 

be omitted from the PDF. 
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